Description

Refreshed my old AMD FX8350 build with an x99 set up. New Processor, Ram, Mobo, Graphics Card, and Power Supply.

6800K - 4.3 Ghz @ 1.3v Dominator - 3200mhz @1.35v No OC on the graphics yet

Log in to rate comments or to post a comment.

Comments

  • 41 months ago
  • 3 points

I'd say the cables are pretty well kept. Don't listen to Tabbott. He's just a hater because he doesn't have a build. Good rig dude!

  • 41 months ago
  • 2 points

Thanks Man!

  • 41 months ago
  • 1 point

Why did you change the power supply? Was it not doing the job?

  • 41 months ago
  • 1 point

Needed another 4pin EPS for the x99 platform. Was able to run the system on the old power supply with just the 8 pin connector but couldn't get over 4.0ghz at decent voltage.

  • 41 months ago
  • 1 point

I'm pretty sure you could of done better with the price. I building a gaming/video editing pc for about $1600 with dual monitors, I5-7600k, Corsair H100i v2, gtx 1060 6gb, 250gb ssd, 3tb hdd, 16gb ddr4-3000, corsair C70 vengeance, and windows 10 pro. I recommend getting the pro version of windows 10 because it has bitlocker and remote desktop control.

  • 41 months ago
  • 1 point

Completely forgot to change the prices to what I paid. I got the 6800K and Strix x99 on BF from Microcenter. Think the processor was ~$329 and the mobo was just under $300 after the $30 bundle deal. Paid ~$400 for the 1070. Case, Cooler, Windows 10, Optical, and storage were all transplants from my last build.

Not sure on the price comparison between an i5/1060/16gb build's price with this since they are significantly different machines.

  • 41 months ago
  • 1 point

nice build though!

  • 36 months ago
  • 1 point

Hey there great build!

Was just wondering if you've had any troubles with your Asus X99 Strix board? I've read a tonne of terrible reviews including fried CPUs, dead ram slots, Q Code 00 and just a bunch of RMA's.

Cheers! :)

  • 41 months ago
  • 0 points

Pretty. Except for cables.