add arrow-down arrow-left arrow-right arrow-up authorcheckmark clipboard combo comment delete discord dots drag-handle dropdown-arrow errorfacebook history inbox instagram issuelink lock markup-bbcode markup-html markup-pcpp markup-cyclingbuilder markup-plain-text markup-reddit menu pin radio-button save search settings share star-empty star-full star-half switch successtag twitch twitter user warningwattage weight youtube

Linux : Intel HD Graphics Driver Issues

December454

35 months ago

Recently I have been trying get Steam and a few games running on my PC, and it has been nothing but problematic. First off Steam itself refused to launch (likely a driver issue), and the only workaround that I could find was downloading the I386 version (which may be causing other issues). So now that Steam was working, I decided to try a few games. War Thunder gives an error message concerning graphics cards and drivers and refuses to launch. The integrated Ironlake graphics on my I3 don't even meet the minimum system requirements, so I thought that may be the issue. I tried a little free to play game called Unturned which even limped by on the integrated graphics of a seven year old Celeron 900. I received no error but the game still refuses to launch.

I am kind of at a loss here. Throughout all of this I have been trying to install the official Intel drivers multiple ways to no avail and nothing has worked properly. Here is some information that may help.

-I am running Ubuntu Gnome 16.10 64bit. -The needed driver is the I965 graphics driver for Ironlake integrated graphics. -When initially trying to launch Steam via the terminal, it would give a series of errors all related to this driver. -When attempting to use the official Intel Graphics Update Tool, I always receive the error : NO_PUBKEY 611B903CAB97EA77, E:The repository 'https://download.01.org/gfx/ubuntu/16.10/main yakkety InRelease' (it says I don't have the public key to gain access to the repository, so I don't even know if this is on me)

I hope that someone more knowledgeable than myself can aid me. Feel free to ask for any more info. Thank you all.

Comments

  • 35 months ago
  • 1 point
  • 35 months ago
  • 1 point

Okay, I ran that and it got through the driver install. I will finish things up soon and tell you if it worked. Thank you very much.

  • 35 months ago
  • 1 point

You're welcome.

  • 35 months ago
  • 1 point

Well that didn't seem to solve the problem. I may try to find a solution again later, but currently I am going to try to get a copy of Windows. I have a few product keys for Windows 7 Home Premium, and I ultimately wanted Windows on this machine anyway. Thanks again.

  • 35 months ago
  • 1 point

Normally I don't recommend invoking a program with some unknown from wget. You might want to run those two commands separately.

  • 35 months ago
  • 1 point

I see some similar errors here

https://ubuntuforums.org/showthread.php?t=2344530

couple of fixes posted. But I dont understand gnome language :)

  • 35 months ago
  • 1 point

I think things are sorted out now, but thanks nonetheless.

Sort

add arrow-down arrow-left arrow-right arrow-up authorcheckmark clipboard combo comment delete discord dots drag-handle dropdown-arrow errorfacebook history inbox instagram issuelink lock markup-bbcode markup-html markup-pcpp markup-cyclingbuilder markup-plain-text markup-reddit menu pin radio-button save search settings share star-empty star-full star-half switch successtag twitch twitter user warningwattage weight youtube