add arrow-down arrow-left arrow-right arrow-up authorcheckmark clipboard combo comment delete discord dots drag-handle dropdown-arrow errorfacebook history inbox instagram issuelink lock markup-bbcode markup-html markup-pcpp markup-cyclingbuilder markup-plain-text markup-reddit menu pin radio-button save search settings share star-empty star-full star-half switch successtag twitch twitter user warningwattage weight youtube

Cloud Core Mic has Static with PC but not with Other Gadgets.

claudekenny234
  • 28 months ago

Bought a HyperX Cloud Core about a month ago and it started developing this static noise whenever I'd use the mic. Tried using it with my iPad and phone and voila, no static noise at all.

Aside from using noise cancellation and buying a sound card, is there a possible fix to this?

Comments

  • 28 months ago
  • 2 points

Maybe get an external DAC?

  • 28 months ago
  • 2 points

Yeah, this could be something on your mobo causing static.

Have you tried plugging it into both the back IO panel and the front case IO? It could appear on one and not the other.

Sort

add arrow-down arrow-left arrow-right arrow-up authorcheckmark clipboard combo comment delete discord dots drag-handle dropdown-arrow errorfacebook history inbox instagram issuelink lock markup-bbcode markup-html markup-pcpp markup-cyclingbuilder markup-plain-text markup-reddit menu pin radio-button save search settings share star-empty star-full star-half switch successtag twitch twitter user warningwattage weight youtube