PCPartPicker

  • Log In
  • Register

Speeds not right? More wifi problems...

Forum Search

Guidelines

  • Be respectful to others
  • No spam
  • No NSFW content
  • No piracy or key resellers
  • No link shorteners
  • Offensive content will be removed

Topic

dwang040 2 months ago

So, after reverting from Lede back to the stock bios and doing power cycles etc, my wifi speeds were back to normal. Roughly 290Mbps down and 12Mbps up (which is what I usually get). However, starting this week, the max I can get is about 80Mbps. Whether it's when I'm downloading a game in steam, my max is around 80Mbps, if I take a speed test on Speedtest.net or dslreports.com, I only get around 80Mbps. However, when I take the speed test on the google search, I get 240Mbps, and when I take a speed test on the linksys smartwifi page, I get 297Mbps. And that's with wired. I tried to take a test with my wifi adapter, and again, I can usually get the full speeds, but this time, I only got 2Mbps. Actually, the test didn't even finish cause I lost connection. Any ideas as to why my speeds got throttled? I've searched around the linksys router controls and I don't see any sorts of priority what-so-ever, and I don't recall changing anything with the settings on the router nor have I touched my pc settings.

Thanks!

Comments Sorted by:

BetrayedPredator 1 point 2 months ago

Yeah sounds like you are getting throttled by your ISP

Call your ISP

Also steam will never saturate a fast WiFi network

dwang040 submitter 2 Builds 1 point 2 months ago

Possibly, I don't know why comcast would since they haven't emailed me any issues. I'll give them a call anyways.

And when I say I used steam, usually when I download a game, I can get up to 300Mbps, whereas this time, I'm getting less than 8Mbps. Same goes with all my other game downloads in Origin and Battle.net

Rin_Itoh 1 point 2 months ago

Steam is usually limited on their end. Whether it is a lot of people downloading games or what, they usually won't be able to saturate a connection like BetrayedPredator said. I agree that this sounds like an ISP issue since the speeds are changing so rapidly. When did you take the speed tests? What is the medium for your connection? Do you have cable, dial-up, DSL, etc.? I have had Comcast in the past and they don't mention anything about a data cap in the package, but I had a limited of a terabyte of data and I was coming very close to it every month. They ended up charging me extra, but they might throttle your speed.

dwang040 submitter 2 Builds 1 point 2 months ago

Hi, thanks for the response. I have cable and usually, my mean for my testing is roughly 300mbps. Checking on Verizon, I did not reach that terabyte cap, nor have I ever reached it in the past. In the end, I ended up just factory reseting my router, and everything is back to normal. I still don't know what the cause is, but again, everything is working fine now. Wired speeds are back to normal, and so are wireless speeds. Maybe the router just needed a reset or something.

Crazyfool 1 point 2 months ago

it might have updated firmware after the reboot which could have been needed due to a network update on Verizon's end. I've personally seen the docsis engineers at a cable company I worked at do this before after headend hardware changes/updates, but usually they force reboot the specific ones they think needs the fix right away during the night etc. The rest they just leave alone to update on their own next time they reboot, but it could still have had an issue and needed the update.

dwang040 submitter 2 Builds 1 point 1 month ago

Late reply, sorry, but tbh, I'm not sure anymore. I've contacted xfinity twice, and both times, they "run their diagnostics and what not" and tell me everything is working on their end. They do their typical modem restart which never works. What does work (that I've noticed) is that if I restart my router, my speeds will go back to normal for one day, and the next day, it'll be back to the sub 100mbps, I'll restart the router again, 300mbps, then the next day, it drops back down, and so on and on.

[comment deleted by staff]