PCPartPicker

  • Log In
  • Register

Display Port No Signal

Forum Search

Guidelines

  • Be respectful to others
  • No spam
  • No NSFW content
  • No piracy or key resellers
  • No link shorteners
  • Offensive content will be removed

Topic

DargoIronbear 4 days ago

Hi. So was on my machine earlier today, no worries. Working as normal. Come home from work my wife says it's not working. So the machine is on, just no display port signal. Turn PC off swap it out for an HDMI turn it back on and get a signal for it. Turn it off plus the display port cable- no signal. Monitor is an Asus VG248. Nice but I need to upgrade. My graphics card is an Asus ROG Strix GTX 1080. Any thoughts on what I should check next. Possible my 6 or 3 year old were in pushing buttons when no one was looking.

Comments Sorted by:

hellfire19981 1 point 3 days ago

the displayport port may have just gone bad. it happens a lot with the VG248, VG278Q, VG278QE, and others by Asus. probably a hardware issue. I have a VG278Q and I admit its had intermittant issues before.

Rin_Itoh 1 point 3 days ago

Try the DP connector on another monitor/ TV to try and narrow it down. Since we know that HDMI works then it is not the PC/ GPU. It is also not the monitor going completely bad since the HDMI works there as well. It can be a bad DP port on monitor, GPU, or bad cable is what I believe.

DargoIronbear submitter 1 point 1 day ago

So I picked up a HDMI/digital port cable and it works when the HDMI is plugged into the monitor but not when the digital port is plugged into the monitor. So bad port on the monitor. Thanks for the info everyone

acewingman 1 point 3 days ago

Grab a DVI or HDMI cable and try it out.