add arrow-down arrow-left arrow-right arrow-up authorcheckmark clipboard combo comment delete discord dots drag-handle dropdown-arrow errorfacebook history inbox instagram issuelink lock markup-bbcode markup-html markup-pcpp markup-cyclingbuilder markup-plain-text markup-reddit menu pin radio-button save search settings share star-empty star-full star-half switch successtag twitch twitter user warningwattage weight youtube

Sound Issues, at wits end

kingkaing

10 months ago

I have almost lost it trying to resolve the sound within my computer. I just finished my first PC build and everything works but the onboard sound

What works: -Front headphone jack -Rear speaker jack

What doesn't: -On board motherboard sound -Sound to the monitor

Motherboard is a Asus z370-a

-I have reinstalled the drivers and have checked the BIOs as well. I do not know what else to do...

Any help would be appreciated

Comments

  • 10 months ago
  • 1 point

What monitor and how are you connecting the monitor? Displayport, HDMI, or DVI-D? Displayport and HDMI should have sound but an DVI-D will require an audio jack with the monitor's audio port to the motherboard's Audio I/O port, the lime (green) ports.

Did you double check the Sound's Playback as well? Make sure it's not muted on accident and is the Playback's Default set to the monitor when it's connected?

Has the Realtek Audio Driver been uninstalled and reinstalled?

If OS is Windows 10 64-bit then from the Audio Download page it's Version 6.0.1.8496, 2018/09/06.

If OS is Windows 7 64-bit then use Version 6.0.1.8199, 2017/09/04.

Vice versa could do this too instead is going to Windows Logo (START) > Device Manager > Sound, video, game controllers and select this. > You should see some audio drivers like NVIDIA High Definition Audio and Realtek High Definition Audio. Select NVIDIA High Definition Audio first and try Update Driver Software and do the same for Realtek High Definition Audio too. In your case using the GTX 1060 [basing on your profile here and your latest part list] you would be using NVIDIA High Definition Audio for the monitor.

Another thing to do is try the Troubleshooting on Sound and see what it finds about the Sound.

Or may have to rollback to previous Windows Update and reboot the computer too (but this seems to only be an issue more if your sound device isn't detected by Windows 10 versus a no sound but sees the Sound device).

Or another way about is to find your NVIDIA drivers for your graphics card (assuming it's GeForce GTX 10 series) then download DDU which you choose a Download Location near you for this. Do a clean uninstall and restart using DDU (Display Driver Uninstaller) when you have that software installed then reinstall your graphic's drivers too when DDU is done.

This could fix the Audio for your graphics card but still make sure the Playback's default is set on the monitor too after doing a reinstall of the driver.

  • 10 months ago
  • 1 point

I tried all the combination you recommended with still no luck. The audio for the headphones and rear speaker jacks still work which puzzles me.

  • 10 months ago
  • 1 point

I have also now notices that there is no sounds for any games through the headphone and rear speakers, but YouTube playback is just fine through those systems.

  • 10 months ago
  • 1 point

So you have sound for your headphones with back and front but still no monitor making a sound? Hmm... then has "Speakers" been set as Default with Playback? It may all depend what worked before or not when it comes to monitors. So change the Sound's Playback until you hear something but usually Speakers tend to be the first default. Who knows too since anything can be different or changed when Windows 10 updates occur.

Have you tried changing a different HDMI or Display port cable as well?

This may not always work and is the last resort to do but sometimes reinstalling Windows 10 could work, but backing up your personal data first. Again it's the last resort to do and would hold this off until you tried a lot methods first.

  • 10 months ago
  • 1 point

Right click on the little speaker icon in the lower right of the task bar and select each of the play back devices until you get sound. Its a long shot but ya never know.

Sort

add arrow-down arrow-left arrow-right arrow-up authorcheckmark clipboard combo comment delete discord dots drag-handle dropdown-arrow errorfacebook history inbox instagram issuelink lock markup-bbcode markup-html markup-pcpp markup-cyclingbuilder markup-plain-text markup-reddit menu pin radio-button save search settings share star-empty star-full star-half switch successtag twitch twitter user warningwattage weight youtube