add arrow-down arrow-left arrow-right arrow-up authorcheckmark clipboard combo comment delete discord dots drag-handle dropdown-arrow errorfacebook history inbox instagram issuelink lock markup-bbcode markup-html markup-pcpp markup-cyclingbuilder markup-plain-text markup-reddit menu pin radio-button save search settings share star-empty star-full star-half switch successtag twitch twitter user warningwattage weight youtube

Newly Bought RTX 2080 and Screen Tearing

winona78

12 months ago

Hi Guys,

I just bought an RTX 2080 to match with my Alienware AW3418DW and installed it last night. Overall, the thing is a massive improvement over the RX580 I had. Previously, the RX580 was matched with a Freesync monitor so I never had screen tearing.

After hooking this card up, the FPS and everything was great, but there was periodic screen tearing. Any cause for the tearing? Since this monitor is 100hZ/120hZ, should I frame cap these games to that, or does G-Sync take care of that automatically? Any other things I need to know about G-Sync?

Thanks!

Comments

  • 12 months ago
  • 3 points

did you enabled G-sync from Nvidia control panel(second) and the monitor(First) ?

  • 12 months ago
  • 2 points

I did set it up in the Nvidia control panel, but not the monitor. Sounds like this could be the problem.

  • 12 months ago
  • 1 point

i don't think this is the problem. i think you should limit the frame rate to 144hz using riva tuner/ MSI AB . i found this thread it might be helpful.

  • 12 months ago
  • 1 point

Are you hooked up using a displayport cable?

  • 12 months ago
  • 1 point

I am using a displayport cable.

  • 12 months ago
  • 1 point

Manually enable gsync from nvidia control pannel

  • 12 months ago
  • 1 point

This was enabled upon driver install.

  • 12 months ago
  • 1 point

Make sure Vsync is checked to on in the game you are playing, and it’s enabled in the monitor.

  • 12 months ago
  • 1 point

VSync always helped me out previously since my old monitor was 60/72hZ. After enabling it now, it sets the static FPS at 60 only.

[comment deleted]
[comment deleted]

Sort

add arrow-down arrow-left arrow-right arrow-up authorcheckmark clipboard combo comment delete discord dots drag-handle dropdown-arrow errorfacebook history inbox instagram issuelink lock markup-bbcode markup-html markup-pcpp markup-cyclingbuilder markup-plain-text markup-reddit menu pin radio-button save search settings share star-empty star-full star-half switch successtag twitch twitter user warningwattage weight youtube